IQ error after GPS signal is fixed

What does this error mean?

I am using Forerunner 745.

My observations when this happens:

  • watch doesn’t have Bluetooth connection to phone
  • phone doesn’t have network connection
  • both connections are present but I deleted a route from webpage and I get “Invalid route” message on startup

Maybe something changed in latest versions because I have in my memory that all above situations worked fine before.

I disabled Bluetooth on phone on purpose to test it. First I discovered this problem when I didn’t have phone with me.

After few tests I get this error in all three scenarios:

  • when I don’t have Bluetooth connection to phone
  • or when phone doesn’t have network connection
  • or when I delete route and then start application (watch is connected to phone and phone has network connection)

This is problem when phone doesn’t have network connection (especially in mountains) but I still want to use application with preload route and maps.

Ok, thanks. I’m taking a look. Its likely that it is assuming a connection at some point when it shouldn’t.

It appears there’s an intermittent issue downloading routes, which is causing the app to crash. We’re looking to release a fix which will prevent the device from crashing and to fix the root cause.

1 Like

Ive also started to get the iq error message. If there is no Internet or Bluetooth connection it will not open a downloaded map. I have a 50 mile ultra marathon coming up so was making shure it would work with no external connection.
My watch is a garmin venu sq.

Thats interesting, ive just deleted the file and re downloaded it. It finished at 220% downloaded complete!

Thank you David, if i could find the file i would gladly send it to you but i struggling to find it.
Thank yo for looking into it.

Sent you a private message

Email sent, i hope the file is of use to you.

Many thanks again.

Currently I am away. When I am back in a couple of days I will search for a file and send it to you.

Thanks - that was really useful. The error is in the same place I saw it myself, but it’s still not clear what’s causing it.

If you’d be willing, I could email you a version of the app with some extra logs turned on and you could install it. It just requires you to copy the file on to the watch in the /GARMIN/APPS folder. I can share instructions. You’d then run it, see the error (hopefully) and send the app logs back to me to allow me to see what’s happening.

Let me know and I’ll email you instructions

If it helps then yes i can give it a go! Now i know what im looking at.

Thanks. Ill email you shortly

I’ve emailed you a new version, but I’ve also released 1.0.5 which has a number of stability improvements. It also has a new menu item which will allow you to reset all the route data. You might want to try that and let me know whether it helps at all.

I haven’t managed to recreate the issue yet, so it may not fix it, but it might stop the app from crashing.

If I reset data then application is working normally when there is no Bluetooth connection or phone doesn’t have network connection.

But when I load route again, disable Bluetooth on my phone and reopen application then problem is still there.

There’s a better fix for this in 1.0.6. Let me know if it still happens after upgrading - I found a problem when a route is loaded but you are offline which may cause the app to crash.

I did few quick tests and it’s working as expected.

Thank you for your effort and quick responses!

Good to hear and thanks for reporting it. Hopefully fixed for good now.

Hi, sorry for restarting an old thread but this exact same issue is happening to me as well on a Venu 3. I noticed that everytime I try to load the app with the Bluetooth connection with my phone switched off, the app crashes immediately after locking on the GPS signal.

I was testing this scenario of disabling Bluetooth to test out the offline maps feature. But it simply crashes the app and shows me the Connect IQ error symbol on my Venu 3.

Hi, would you be willing to check the logs for me? They may be already on your watch, but more likely we’ll need to send you a temporary version to try. If so, can you drop me a mail at